Google Sync looping every 20 secs on Automatic

Need help with VueMinder Pro or Ultimate? Ask your questions here.
IanS
Posts: 39
Joined: Fri Jul 08, 2011 12:47 am
Location: United Kingdom

Google Sync looping every 20 secs on Automatic

Post by IanS » Fri Jul 08, 2011 12:57 am

Hi,

I am using the Pro Trial v8.2.1 installed on two PCs. It has been 2-way syncing to Google Calendar without any issues via the Automatic option. However,in trying to determine the root cause of another issue, I set up another test calendar and published/subscribed to webspace that I have, I now see the main calendar syncing to Google around once every 20 seconds or so when the sync option is set to Automatic. If I set the option to 5 mins, it syncs every 5 mins. I have since removed that test calendar but the problem remains.

To add to that, I also sync to the Google Holidays calendar, and when that is left to Automatic, it also syncs every 20 seconds or so.
Last edited by IanS on Fri Jul 08, 2011 6:44 am, edited 2 times in total.

IanS
Posts: 39
Joined: Fri Jul 08, 2011 12:47 am
Location: United Kingdom

Re: Google Sync looping on Automatic

Post by IanS » Fri Jul 08, 2011 1:44 am

I have just tried the other PC, that seems worse!

It's syncing every 10 seconds or so, regardless of sync setting (other than Manual). I did properly exit Vueminder each time that I changed the sync frequency.

I have also tried deleting and re-adding the calendar.

IanS
Posts: 39
Joined: Fri Jul 08, 2011 12:47 am
Location: United Kingdom

Re: Google Sync looping on Automatic

Post by IanS » Fri Jul 08, 2011 6:34 am

I have now installed the trial on my remaining PC, so it is a new install from scratch. The sync (on Automatic) is about once every 14 seconds. So it looks like the problem is not with any configuration issue or corruption on the two other PCs.

User avatar
VueSoft
Dan Chartrand
Posts: 3851
Joined: Sat Aug 23, 2008 12:39 am
Location: St. Louis, Missouri, USA
Contact:

Re: Google Sync looping every 20 secs on Automatic

Post by VueSoft » Fri Jul 08, 2011 3:10 pm

Hi IanS, thank you for the information. Google has recently updated their calendar software, and these updates appear to have broken one of the techniques VueMinder was using for syncing. This results in VueMinder constantly thinking that Google Calendar has been updated and needs to be synced again.

A correction has been made for the next version. In the meantime, the only workaround is to set the sync frequency to Manual and press F5 when you need to sync. I'll let you know as soon as the next version is available to download. A beta should be available soon, if you'd like to try it.
Dan Chartrand, Founder
VueSoft LLC | St. Louis, Missouri, USA

IanS
Posts: 39
Joined: Fri Jul 08, 2011 12:47 am
Location: United Kingdom

Re: Google Sync looping every 20 secs on Automatic

Post by IanS » Sat Jul 09, 2011 2:44 am

Hi Dan

Thanks for that, and thanks for being on top of the problem. :)

Yes, I'd like to try the beta when available.

User avatar
VueSoft
Dan Chartrand
Posts: 3851
Joined: Sat Aug 23, 2008 12:39 am
Location: St. Louis, Missouri, USA
Contact:

Re: Google Sync looping every 20 secs on Automatic

Post by VueSoft » Sun Jul 10, 2011 11:23 pm

Hi IanS, the beta is available here:
http://www.vueminder.com/forums/phpBB3/ ... ?f=5&t=577

Please let me know if you try the beta but find the problem hasn't been solved.
Dan Chartrand, Founder
VueSoft LLC | St. Louis, Missouri, USA

IanS
Posts: 39
Joined: Fri Jul 08, 2011 12:47 am
Location: United Kingdom

Re: Google Sync looping every 20 secs on Automatic

Post by IanS » Mon Jul 11, 2011 1:17 am

Hi Dan,

Problem solved. :) Thanks for the speedy resolution.

IanS
Posts: 39
Joined: Fri Jul 08, 2011 12:47 am
Location: United Kingdom

Re: Google Sync looping every 20 secs on Automatic

Post by IanS » Mon Jul 11, 2011 2:22 am

Bad news - although it is working fine on my Vista (x64) laptop, I've still got the problem on my two XP SP3 desktops.

One thing that I did (and I can't believe that it is connected) is that I installed on the one XP system, and then left Vueminder running whilst I installed it on the other XP system (having exited the existing version of Vueminder). Closing one system down makes no difference.

And I have just checked back on the laptop and that is still OK. So is there an issue only on XP? Or is there something on the XP install that has not been overwritten by the Beta install?

IanS
Posts: 39
Joined: Fri Jul 08, 2011 12:47 am
Location: United Kingdom

Re: Google Sync looping every 20 secs on Automatic

Post by IanS » Mon Jul 11, 2011 7:43 am

IanS wrote:Bad news - although it is working fine on my Vista (x64) laptop, I've still got the problem on my two XP SP3 desktops.
Hold fire on that - it now appears to be working on one XP system (I have rebooted, but I have also removed one security product that was loaded on both XP systems but not on Vista).

I'll have to look at the other XP system before I can say for certain, so bear with me.

IanS
Posts: 39
Joined: Fri Jul 08, 2011 12:47 am
Location: United Kingdom

Re: Google Sync looping every 20 secs on Automatic

Post by IanS » Mon Jul 11, 2011 3:32 pm

OK, got the other XP system working. Uninstall and then reinstall, delete Google Calendar and readded it. All seems OK now. Sorry about the confusion.

Post Reply