Server offline

Need help with VueMinder Pro or Ultimate? Ask your questions here.
Jayne
Posts: 10
Joined: Thu Aug 11, 2016 4:44 pm

Server offline

Post by Jayne » Thu Feb 01, 2018 3:11 pm

VueMinder shows that server is offline. Click to reconnect gives error message: A problem occurred while attempt to connect to the server: invalid field in source data: 0

Server shows running in MySQL. I stopped the server through MySQL and then restarted. Seems to start up fine there. However VueMinder still can't connect (same error message). I rebooted just in case. No luck.

Any help? Thanks.

User avatar
VueSoft
Dan Chartrand
Posts: 3924
Joined: Sat Aug 23, 2008 12:39 am
Location: St. Louis, Missouri, USA
Contact:

Re: Server offline

Post by VueSoft » Fri Feb 02, 2018 1:03 am

Hi Jayne, it sounds like the MySQL Server database has become corrupted. Please follow these steps to fix the problem:

1. Exit VueMinder on all computers by using the "File -> Exit" menu command.
2. Open MySQL Workbench and connect to the server.
3. In the Navigator, right-click the “vueminder” schema and select “Drop Schema” from the popup menu. This will delete any previously shared calendars from the server.
4. Restart VueMinder on all computers.
5. On all computers except one, delete the calendars that were shared. Make sure these calendars still exist on one of your computers.
6. On the computer where the calendars were not deleted, open the Calendar Properties and select “Do not sync” on the Sync tab.
7. Open the Sharing Options on each computer. Clear the host name, username, and password. Click OK.
8. Re-open the Sharing Options and re-enter the connection information.
9. On the computer where your calendars were not deleted, open the Calendar Properties again and re-enable sharing with VueMinder on other computers, via the Sync tab.
10. The shared calendars should automatically appear on your other computers.

I hope that helps. Please let me know if you have any other questions.
Dan Chartrand, Founder
VueSoft LLC | St. Louis, Missouri, USA

Post Reply