can't synch

Need help with VueMinder Pro or Ultimate? Ask your questions here.
Posts: 3
Joined: Tue Jun 10, 2014 7:58 am

can't synch

Post by netgeorger » Wed Oct 25, 2017 2:18 pm

I can not synch to my network calendars. We are a small office with a Qnap Nas and four computers. I originally installed the mysql database for VueMiner on the Qnap and this worked without any problems at first. Once in awhile the computers would not be able to synch in the morning but in the afternoon when I ran the share connect Test it was fine. No explanation. We have had a series of things happen to the Nas we moved and had to re establish a new Ip for it . We then had an incident with our network drive being held for ransom. Luckily the drive was just locked and not encrypted. We got in at a low level and copied all the files over to a new share folder different name. Then when I ran a share TEST everything was fine. Unfortunately everything was fine just on my computer running a netscan -a -n cmd I can see that 3306 port is listening on my computer but it is not present on the other computers. I then tried to get port 3306 open in my Mikro Tek router but either I didn't execute the correct instructions or what. Nothing changed on the other computers. I am now thinking it was a mistake to put the data base on the Nas. I am wondering how to fix this problem. Maybe it would be better to put the database on my secretaries computer and some how transfer all the data in the database to the new installation. In my computer when I test for connection it is instantaneous and I can look at the logs which show when the activity stopped on the other computers. The lack of share capabilities on our computers is unsustainable and is causing huge problems and errors in scheduling.

User avatar
Dan Chartrand
Posts: 3952
Joined: Sat Aug 23, 2008 12:39 am
Location: St. Louis, Missouri, USA

Re: can't synch

Post by VueSoft » Wed Oct 25, 2017 11:11 pm

Hi netgeorger, it sounds like there's a problem with the connection to the NAS from your other computers on port 3306. I'm not sure why it would work from one computer but not the others. Unfortunately, I'm not familiar with your model of NAS or Mikro Tek routers, so I can't offer any specific advice on how to fix the router settings to allow access from your other computers.

If you'd like to transfer the database to your secretary's computer, you can follow these steps:

1. Make sure VueMinder is fully exited on ALL computers.

2. Start MySQL Workbench and connect to your server.

3. Click the “Server -> Data Export” menu command.

4. Check the box for exporting the “vueminder” schema (only), and then click the “Start Export” button.

5. When the export is completed, the log will indicate the location of the exported data, which will contain a number of SQL files. Copy these files to your secretary's computer.

6. On your secretary's computer, install MySQL Server by following the steps in the documentation linked below:

7. After installing MySQL Server, start MySQL Workbench and connect to MySQL Server on your secretary's computer. If you're unable to connect, adjust the firewall settings on your secretary's computer to allow TCP traffic on port 3306, as described in the troubleshooting section of the documentation.

8. Select the folder where you copied the backup files (step 5) for “Import from dump project folder” and then click the “Start Import” button. After the import completes, the new server should have exactly the same data as the old server.

9. Restart VueMinder on each computer. Open the Sharing Options and enter the name or local IP address of your secretary's computer.

I hope that helps. Please let me know if you have any other questions.
Dan Chartrand, Founder
VueSoft LLC | St. Louis, Missouri, USA

Post Reply