Connecting to Exchange

Need help with VueMinder Pro or Ultimate? Ask your questions here.
johnlocke
Posts: 3
Joined: Fri Apr 17, 2015 2:43 pm

Connecting to Exchange

Post by johnlocke » Tue May 12, 2015 1:50 pm

Hello,

Setting up my Microsoft Exchange calendar on VueMinder is the final piece of the puzzle to unify multiple emails and calendars and finally have that satisfied feeling that comes from an organized setup. Unfortunately, I have been running into a recurring error when trying to add an exchange calendar.

After entering credentials per this topic:

http://www.vueminder.com/forums/phpBB3/ ... ange#p4325

I see the popup to add a calendar from Microsoft Exchange. However when I click on "My Calendars" and error message pops up stating "Error: The response received from the service didn't contain valid XML."

I'm using VueMinder Ultimate 11.2.8. I've tried all sorts of combinations of User name/Domain name to no avail. I can browse to https://connect.XXXXX.com/owa/ and enter my Domain\user name and password and have no problem accessing email and calendars.

Does the error message I'm seeing in VueMinder provide any indication of what I could be doing wrong? Any help is greatly appreciated.

Thanks,
John

User avatar
VueSoft
Dan Chartrand
Posts: 3878
Joined: Sat Aug 23, 2008 12:39 am
Location: St. Louis, Missouri, USA
Contact:

Re: Connecting to Exchange

Post by VueSoft » Tue May 12, 2015 6:46 pm

Hi John, is your Exchange Server hosted remotely (not on your local network)? If so, try leaving the domain name blank. If the Exchange Server is on your local domain, then just leave the "Use default credentials" box checked.

Also, do you know which version of Exchange Server you’re using? VueMinder requires Exchange 2010 or later. In addition, the Exchange Server should be running the Autodiscover service. You might need to check with your IT group to see if the Autodiscover service is enabled.

Typically, if the Autodiscover service is running, you should only need to enter your email address (or mailbox name) and password. If you're getting prompted to enter a URL, the Autodiscover service probably isn't running, and the URL you're manually entering is probably incorrect. VueMinder connects through Exchange Web Services. In other words, the URL won't be the same one you use in your web browser. Again, you might need to check with your IT group to determine the correct URL for accessing Exchange Server through EWS, if there's some reason they disabled the Autodiscover service.
Dan Chartrand, Founder
VueSoft LLC | St. Louis, Missouri, USA

jhlui1
Posts: 2
Joined: Thu Aug 13, 2015 2:08 pm

Re: Connecting to Exchange

Post by jhlui1 » Thu Aug 13, 2015 3:18 pm

Similar issue (we're on Exchange 2013 server and the Outlook Web App).

Our normal web mail URL looks like https://webmail.server.domain/owa (configured using MS's suggestions to re-direct the full standard URL to a user-friendly version.)

Visiting https://webmail.server.domain/ews/exchange.asmx

Produces a page that reads out WSDL information:

Service

You have created a service.

To test this service, you will need to create a client and use it to call the service. You can do this using the svcutil.exe tool from the command line with the following syntax:

svcutil.exe https://realexchangehost.server.domain: ... vices.wsdl

That, and looking at the properties on our Outlook Exchange Account setup under Account Settings -> Change -> More Settings... -> Connection -> Exchange Proxy Settings...

Advanced settings revealed that we have a proxy server setup at https://oa.anotherhost.domain

Then going back into VueMinder and again using the Add Exchange Calendar... function, this time VM picked up a different setting seen under the Options -> Email Settings window:

Mailbox name: my@maildomain.domain
Server URL: https://ews.anotherhost.domain/EWS/Exchange.asmx
Username: ADaccount
Domain: MyDomain

This still isn't quite correct because the Send Test e-Mail says that ews.anotherhost.domain doesn't exist (which it doesn't). I think it's going to be a variation of the physical host shown in the WSDL URL, plus the /EWS/Exchange.asmx suffix. I wish this particular window allowed me to directly edit the values, so I can test without having to re-do the entire Add a Exchange Calendar dialog every time.

This has taken several shutdown and restarts of VueMinder to get it to pick up the settings at this point, but I'm still not connected. But I figured I'd share my progress with the same issue. (our old Exchange server 2010 had regular auto-discovery set up, so it was easy to connect VueMinder to it. The new 2013 version is much more complicated.

Update: 2:31pm PT - It worked! (yea.)
I combined the WDSL URL shown above from the hit against the webmail server with the suffix from the auto-detected (but incorrect) one, And this time during the Add Exchange Calendar dialog, gave it the usual:
me@me.domain
Use default credentials (unchecked - just to be sure)
me@me.domain
password
ADDOMAIN
...waited while it pauses and can't find the server, then prompts for the URL.

https://realexchangehost.server.domain: ... hange.asmx

It's now connected and Synchronizing again.

User avatar
VueSoft
Dan Chartrand
Posts: 3878
Joined: Sat Aug 23, 2008 12:39 am
Location: St. Louis, Missouri, USA
Contact:

Re: Connecting to Exchange

Post by VueSoft » Thu Aug 13, 2015 11:52 pm

Hi jhlui1, welcome to the forums and thank you for the information. I'm glad you were able to get it working.
Dan Chartrand, Founder
VueSoft LLC | St. Louis, Missouri, USA

Radonkey
Posts: 1
Joined: Thu Aug 20, 2015 3:54 am

Re: Connecting to Exchange

Post by Radonkey » Thu Aug 20, 2015 4:16 am

I am getting the same error of "Error: The response received from the service didn't contain valid XML." when I click on "My Calendars". I've read this topic thread a few times and I still am confused on how to fix this problem. If I can sync my Outlook Exchange, VueMinder does not become a viable calendar solution for me, so I really need help in getting this to work!!

User avatar
VueSoft
Dan Chartrand
Posts: 3878
Joined: Sat Aug 23, 2008 12:39 am
Location: St. Louis, Missouri, USA
Contact:

Re: Connecting to Exchange

Post by VueSoft » Thu Aug 20, 2015 5:39 pm

Hi Radonkey, welcome to the forums. Could you take a screenshot of the settings you are attempting to use on the "Connect to Microsoft Exchange" window, and send this to support@vueminder.com? I'll take a look to see if anything appears wrong with the settings.

Also, please be aware VueMinder can only connect to Exchange Server 2010 or later. If you're using an older version of Exchange Server that might explain the problem.
Dan Chartrand, Founder
VueSoft LLC | St. Louis, Missouri, USA

jhlui1
Posts: 2
Joined: Thu Aug 13, 2015 2:08 pm

Re: Connecting to Exchange

Post by jhlui1 » Mon Nov 02, 2015 4:01 pm

As a simple work-around to this auto-discovery thing not working reliably on all Exchange servers, could VueMinder be modified so that when you click Add Exchange Calendar... and give it your login information, there's an extra box that says
[ ] Overrride auto-detected OWS Server URL, and then when you check it, it just pre-fills what it found (which might be incorrect), but allows the user to paste in the correct URL directly without having to wait for the connection to time-out?

Even more useful would be a button to [Test Connection] so you don't have to exit the dialog while trying to figure out what your correct settings are supposed to be.

User avatar
VueSoft
Dan Chartrand
Posts: 3878
Joined: Sat Aug 23, 2008 12:39 am
Location: St. Louis, Missouri, USA
Contact:

Re: Connecting to Exchange

Post by VueSoft » Tue Nov 03, 2015 1:12 am

Hi jhlui1, thank you for the suggestions.
Dan Chartrand, Founder
VueSoft LLC | St. Louis, Missouri, USA

Post Reply