Can't get smtp for gmail working

Need help with VueMinder Pro or Ultimate? Ask your questions here.
BlueProteus
Posts: 15
Joined: Tue Jan 17, 2012 5:15 pm

Can't get smtp for gmail working

Post by BlueProteus » Sun Oct 05, 2014 9:33 pm

I'd like to have an email sent for some of my reminder alarms.

I've followed the docs for setting this up, and am using smtp.gmail.com as my server.
Using my email address and password for the authentication.
Server requires authorization and Use SSL are both checked.

I've tried ports 465 and 587, and get an error:
"The SMTP server requires a secure connection or the client was not authenticated. The server response was 5.5.1. Authentication required."

Anybody else get this working with gmail?
I know there's an option to use that web-based email service, but I don't want to pay 10 bucks a month for this.

Thanks

User avatar
VueSoft
Dan Chartrand
Posts: 3874
Joined: Sat Aug 23, 2008 12:39 am
Location: St. Louis, Missouri, USA
Contact:

Re: Can't get smtp for gmail working

Post by VueSoft » Sun Oct 05, 2014 9:43 pm

Hi BlueProteus, here are the settings required for Gmail...

Server (SMTP): smtp.gmail.com
Port: 587
User Name: Your Google email address
Password: Your Google password
Server Authentication: Yes (checkmark)
Use SSL: Yes (checkmark)

If this doesn't work, in your Google account settings, try changing the settings to allow access from “less secure apps” (which is a bogus claim by Google, since SSL is used):
https://www.google.com/settings/security/lesssecureapps

Does that fix it?
Dan Chartrand, Founder
VueSoft LLC | St. Louis, Missouri, USA

BlueProteus
Posts: 15
Joined: Tue Jan 17, 2012 5:15 pm

Re: Can't get smtp for gmail working

Post by BlueProteus » Sun Oct 05, 2014 9:52 pm

Hi Dan, thanks for getting back to me so quickly. When I try to set that up for less secure apps, I get this:

"This setting is not available for accounts with 2-Step Verification enabled. Such accounts require an application-specific password for less secure apps access. Learn more"

Is there a way for me to assign such a password myself, or is that something I need from you guys?

BlueProteus
Posts: 15
Joined: Tue Jan 17, 2012 5:15 pm

Re: Can't get smtp for gmail working

Post by BlueProteus » Sun Oct 05, 2014 10:01 pm

Ah, I answered my own question, and seem to have gotten it to work.

I needed to supply a special generated password through gmail security settings, and it looked like it worked!

Thanks...will let you know if I have any other issues.

Post Reply